Flows and Campaigns not loading for some users

Incident Report for Alpine IQ

Resolved

This incident has been resolved. The background maintenance process that caused Flows and Campaigns to load slowly has been rescheduled to run outside heavy traffic hours.
Posted Sep 25, 2026 - 20:41 UTC

Monitoring

Flows and Campaigns are loading normally again. A backend maintenance process was temporarily slowing requests, which made some Flow and Campaign pages load indefinitely. It has cleared, and we're monitoring to make sure it doesn't come back.
Posted Sep 25, 2026 - 20:08 UTC

Update

Flows and Campaigns are loading normally again. A backend maintenance process was temporarily slowing requests, which made some Flow and Campaign pages load indefinitely. It has cleared, and we're monitoring to make sure it doesn't come back.
Posted Sep 25, 2026 - 20:02 UTC

Update

We're starting to see response times return to normal.
Posted Sep 25, 2026 - 19:57 UTC

Investigating

We're investigating an issue where some users can't open Marketing Flows and Campaigns, including the campaign review page, in the dashboard. Affected pages may show a loading spinner that never completes. Messages that are already scheduled or running are not affected.
Posted Sep 25, 2026 - 19:53 UTC
This incident affected: API and Dashboard portal.